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I. Assignment (PCB Design)	


A. Design PCB using Altium Suite	


1.  Obtain your specific circuit to design the corresponding printed circuit board 

(PCB) from the TAs	


2.  Design the PCB using the same parts and follow the PCB design rules to 

generate an error-free net list that is properly laid-out and routed.  Designs 
should be single-sided if possible, and no bigger than 6”x6”.  Finally, the 
student is expected to create plots and miscellaneous design files (Gerber 
files) that could be used to have the circuit boards milled locally or sent out to 
be fabricated professionally. 	



	


B. Upload your PCB design to the PCB milling queue	


1.  Detailed for the upload procedure will be provided by the staff	


2.  Full credit will received for	



a.  Correct error-free PCB net list and Gerber file AND	


b.  On-time submission	



	


C. Upload report using template	


1.  Sample circuit original diagram that you were given in class. ( one page )	


2.  Altium schematic drawing. ( one page )	


3.  PCB layout drawing in 1:1 format. ( one page )	
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•  Introduction	


•  The purpose of this document is to illustrate how to create a new 

project in the Altium Designer.	


•  Setup Procedure 	


•  0.  Install Altium Software	



–  http://www.altium.com/evaluate/en/self-evaluate.cfm#trial	



•  1.  Start the Altium Designer Software.	


–  DXP -> My account -> Set up private license server	


–  See TA for IP and server port	



•  2.  Ensure that the ‘Files’ and ‘Projects’ tabs are located 
somewhere on the screen. Most likely they will be minimized on 
the left side of the window.  If they are not then add them to the 
screen	



–  View > Workspace Panels > System  > Files	


–  View > Workspace Panels > System  > Projects	



II. Altium Designer	
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–  Alternatively you may…	


•  Click on the ‘System’ box in the lower right hand corner of the designer 

and then click ‘Files’ and ‘Projects’ to make the tabs appear.	


–  These will both accomplish the same goal of making the ‘Files’ tab and the 

‘Projects’ tabs visible. All tabs can be dragged and dropped nearly 
anywhere on the designer to suit your personal preferences.  	



•  3.  Create a new PCB Project.  File > New > Project > PCB 
Project  – or –  You may click on the ‘Files’ tab and then under 
the ‘New’ heading you can click ‘Blank Project (PCB)’	



•  This will cause the ‘Projects’ tab to open and display 
‘PCB_Project1.PrjPCB’ with no documents added to it.	



II. Altium Designer	
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•  4.  We will now add a schematic and a PCB to the current project. 	


–  Right click on the project > Add New to Project > Schematic	


–  Right click on the project > Add New to Project > PCB	



•  5.  It is now time to save the new project	


–  a.  Right click on the project > Save Project As…	


–  b.  This will open the familiar windows save dialog box…	



II. Altium Designer	
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–  c.  The designer will allow you to choose a name and where to save 
each individual file (the schematic file, the PCB file, and the Project 
file). It is recommended that you give each file the same name and 
save them all in the same location for simplicity’s sake. Having all 
of your files in the same folder will also make your life easier if you 
need to keep your project on a thumb drive and use a different 
computer. You are not guaranteed the same computer each time 
you enter the lab. 	



•   	



II. Altium Designer	
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•   6.  Now we need to change the paper size from the default size of ‘A’ 
to ‘Letter’ size and also set up some automatic backups	


–  a.  DXP > Preferences > Schematic > General > Default Blank 

Sheet Size -> Letter	


–  b.  DXP > Preferences > System > Backup -> Check the ‘Auto 

save every:’ box	


•  Change the number of minutes to whatever you feel comfortable with 

knowing that it is your work that will be lost if something happens. 
This is not a replacement for you periodically saving your project 
as you work on it. 	



II. Altium Designer	
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•  Adding Parts and Modifying the Schematic	


•  1.  Libraries are a very important part of working with your 

schematic. Libraries are where all of your parts will be found and 
selected from. If you do not have the ‘Libraries’ tab anywhere on 
your screen you should…	


–  a.  Click the ‘System’ box in the bottom right portion of the designer and then 

click the ‘Libraries’ button.	


•  2.  The libraries that are listed are dependent on how the libraries 

were left the last time the designer was used. Since the computers in 
the lab are shared there is a possibility that the libraries that you 
would like to use are not listed.	



•  3.  The libraries that we will be using for this tutorial are:	


–  Miscellaneous Devices	


–  Miscellaneous Connectors	


–  NSC Amplifier	



II. Altium Designer	
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•  If these libraries are not listed at startup then you will have to 
add them. Their probable locations are:	



•  i.  C:\PROGRAM FILES\ALTIUM DESIGNER SUMMER 09\Library
\Miscellaneous Devices.IntLib 	



•  ii.  C:\PROGRAM FILES\ALTIUM DESIGNER SUMMER 09\Library
\Miscellaneous Connectors.IntLib	



•  iii.  C:\Program Files\Altium Designer Summer 09\Library\National 
Semiconductor\NSC Amplifier.IntLib	



II. Altium Designer	
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•  4.  Add a resistor to your schematic page by following these steps 
(below image has red letters corresponding  to the steps 
illustrated):	


–  a.  Make sure you have your schematics page opened	


–  b.  Open the ‘Libraries’ tab	


–  c.  Select the ‘Miscellaneous Devices’ library from the upper drop 

down (if this library is not in the drop down refer to step 3 above)	


–  d.  Type ‘Res3’ into the dropdown textbox below the library listing	


–  e.  Click the ‘Place Res3’ button at the top of the libraries tab	


–  f.  Your cursor will then have a resistor attached to it and you can 

place it anywhere on the schematic	


–  g.  Once you have placed the resistor you can either hit the ‘Esc’ 

key –OR- right click your mouse to stop placing resistors	



II. Altium Designer	
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•  5.  Follow the above steps and place the following parts	


–  a.  From the ‘Miscellaneous Devices’ library:	



•  i.  (4) res3	


•  ii.  (2) Cap Pol1	


•  iii.  (4) Cap	



–  b.  From the ‘Miscellaneous Connectors’ library: 	


•  i.  (1) Header 3	


•  ii.  (1) Header 2H	


iii. (1) Header 2	



–  c.  From the ‘NSC Amplifier’ library	


•  (1) LM741J	



II. Altium Designer	
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•  Notice 1: The difference between the ‘Header 2’ and the ‘Header 
2H’ parts are only in the footprint created on the PCB later. Some 
parts will need to be rotated and this can be accomplished by 
pressing the spacebar while you are placing the part or when the 
part is selected. Try to place the parts more or less like the 
following screenshot.	



•  Notice 2: The ‘Header 2H’ part has been rotated as well as 
mirrored in order to get the 1 pin on top when the part is in this 
orientation. Rotation is accomplished with the spacebar key while 
the mirror is added by right-clicking the part and checking the 
‘mirrored’ checkbox. This does not make any difference on the 
PCB file it just makes your schematic easier to view and 
understand. 	



II. Altium Designer	
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II. Altium Designer	
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6.  It is now time to wire these parts together. 	


a.  You can either click the ‘Place Wire’ icon from the upper 
toolbar or select Place > Wire. Both are illustrated below.	



	



The image cannot be displayed. Your computer may not have enough memory to open the image, or the image may have been corrupted. Restart your computer, and then open the file again. If the red x still appears, you may have to delete the image and then 
insert it again.

II. Altium Designer	
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b.  Once you click this icon your cursor will turn into a crosshair 
with a black X on it. Once you hover over a valid place to connect 
a wire the X will turn red. If the X does not turn red when you 
place the wire a proper connection was not made and this will 
lead to errors later in the process. The red X is illustrated close 
up below. 	



The image cannot be displayed. Your computer may not have enough memory to open the image, or the image may have been corrupted. Restart your computer, and then open the file again. If the red x still appears, you may have to delete the image and then 
insert it again.

The image to the right is connected properly. The X in the 
crosshair has turned red showing that a connection is being made.	


	



II. Altium Designer	
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c.  Using the ‘Place Wire’ tool add wires between the 
components just like the image shown below	



	


The image cannot be displayed. Your computer may not have enough memory to open the image, or the image may have been corrupted. Restart your computer, and then open the file again. If the red x still appears, you may have to delete the image and then 
insert it again.

II. Altium Designer	
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The image cannot be displayed. Your computer may not have enough memory to open the image, or the image may have been corrupted. Restart your computer, and then open the file again. If the red x still appears, you may have to delete the image and then 
insert it again.

	


d.  Once a connection between two points is made the ‘Place 
Wire’ cursor will be ready to select the next beginning point.	


e.  When you are finished placing wire either press the Esc 
key or right-click the mouse to return the cursor to normal 
and stop adding wires. 	



	



II. Altium Designer	
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7.  Now it’s time to add the Power and Ground nets to the 
schematic	



a.  Click the ‘VCC Power Port’ button that is next to the ‘Place 
Wire’ button and place (4) of them in the places shown in the 
image on the next page	



i.  Two of the ports will be renamed from ‘VCC’ to ‘+12V’ 
and the other two will be renamed to ‘-12V’. Naming two 
ports the same thing is the same thing as connecting them 
with a wire but it is a more elegant solution for keeping the 
schematic less congested. 	



1.  To rename a port just double click on the port and its 
properties dialog box will pop up. You can then change 
the text in the ‘Net’ textbox in order to change the name 
of the net. Shown below.	



	



The image cannot be displayed. Your computer may not have enough memory to open the image, or the image may have been corrupted. Restart your computer, and then open the file again. If the red x still appears, you may have to delete the image and then 
insert it again.
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The image cannot be displayed. Your computer may not have enough memory to open the image, or the image may have been corrupted. Restart your computer, and then open the file again. If the red x still appears, you may have to delete the image and then 
insert it again.

	


b.  Click the ‘GND Power Port’ button next to the ‘Place 
Wire’ button and place (6) of them in the schematic in the 
places shown in the image on the next page	



	



II. Altium Designer	
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The image cannot be displayed. Your computer may not have enough memory to open the image, or the image may have been corrupted. Restart your computer, and then open the file again. If the red x still appears, you may have to delete the image and then 
insert it again.

This image shows the Power (+12V and -12V) and Ground (GND) 
nets added to the schematic with red arrows	
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The image cannot be displayed. Your computer may not have enough memory to open the image, or the image may have been corrupted. Restart your computer, and then open the file again. If the red x still appears, you may have to delete the image and then 
insert it again.8.  Now we will use named nets to add connections to our schematic 

without wires.	


a.  Click on the ‘Place Net Label’ icon next to the place wire icon 
–OR- click Place > Net Label.	


b.  Use spacebar to rotate the net label to make it easier to place.	


c.  Place nets in the places shown in the image below.	


d.  In order to rename the net Double click it –OR-  Right click  
and select Properties then change the value in the textbox for 
Net	



i.  In our case the net name will be either Input or Output	
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The image cannot be displayed. Your computer may not have enough memory to open the image, or the image may have been corrupted. Restart your computer, and then open the file again. If the red x still appears, you may have to delete the image and then 
insert it again.

Input and output nets are shown by the red arrows	
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The image cannot be displayed. Your computer may not have enough memory to open the image, or the image may have been corrupted. Restart your computer, and then open the file again. If the red x still appears, you may have to delete the image and then 
insert it again.

 9.  It is now time to annotate all of the unnamed 
components	



a.  Add more descriptive comments to the ports, this 
will make them easier to find on the PCB later	



i.  Change the comment on the input port that reads ‘Header 2H’ and 
make it say ‘Input’	


ii.  Change the comment on the output port that reads ‘Header 2’ and 
make is say ‘Output’	


iii.  Change the comment on the power port that reads ‘Header 3’ and 
make is say ‘Power’	



b.  No two components are allowed to have the same 
designator we must rename them; this can be 
accomplished one-by-one or this can be done 
automatically	



i.  You can do this for each component by hand	


1.  Go to the properties of each component and change the text in the 
Designator field	



II. Altium Designer	
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ii.  –OR- You can do them all at once automatically using 
tools in Altium (much easier)	



1.  Tools > Annotate Schematics Quietly	


2.  Click OK when the dialog box pops up to tell you how many 
changes will be made	


3.  This will automatically add unique designators to each 
component depending on the annotation rules that are currently 
in place	


4.  You may optionally change the annotation rules using Tools > 
Annotate Schematics if you want more control over the way the 
program decides to rename you designators for you. That is out 
of the scope of this tutorial	



	



The image cannot be displayed. Your computer may not have enough memory to open the image, or the image may have been corrupted. Restart your computer, and then open the file again. If the red x still appears, you may have to delete the image and then 
insert it again.
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Your schematic should look something like the one below 
without any question marks on it	


	



The image cannot be displayed. Your computer may not have enough memory to open the image, or the image may have been corrupted. Restart your computer, and then open the file again. If the red x still appears, you may have to delete the image and then 
insert it again.
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10.  We are now ready to update the PCB file	


a.  Design > Update PCB Document ‘nameOfProject.PcbDoc’	


b.  Scroll to the bottom of the window that pops up and uncheck the box 
next to the room that the program is trying to add	


c.  Click Validate Changes, make sure all of the changes get validated	


d.  Click Execute Changes, this will add all of the components and nets 
to your PCB  document	


e.  Close the update window	



11.  The PCB file should have automatically opened for you; if 
not, open it now	



a.  Click View > Fit Sheet to see the board as well as all of your 
components	


b.  You will notice that the components are added outside of the board 
area (black area)	


c.  The components can be dragged onto the board as you place them	



	



The image cannot be displayed. Your computer may not have enough memory to open the image, or the image may have been corrupted. Restart your computer, and then open the file again. If the red x still appears, you may have to delete the image and then 
insert it again.
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12.  Notice how big the circular footprints are for the capacitors 
we added; We will change the footprint used in order to save 
space on our board.	


	



The image cannot be displayed. Your computer may not have enough memory to open the image, or the image may have been corrupted. Restart your computer, and then open the file again. If the red x still appears, you may have to delete the image and then 
insert it again.

a.  Return to the schematic file and open the 
properties dialog on one of the two polarized 
capacitors	


b.  Find the ‘Footprint’ drop down in the 

lower right and change it from 
‘RB7.6-15’ to ‘CAPPR1.27-1.7x2.8’. 
Shown on the next page	



c.  	

Repeat step b for the other polarized 	


	

capacitor	
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d.  Continue to change the footprints of the other four capacitors as well from 
‘RAD-0.3’ to ‘CAPPR2.54-5.1x3.2’	



e.   Update the PCB using Design > Update PCB Document 
‘nameOfProject.PcbDoc’; be sure to uncheck the addition of the rooms in 
the update dialog each time. Validate and execute the changes then go 
back to the PCB document and notice how the footprints have changed 
for the capacitors	
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The image cannot be displayed. Your computer may not have enough memory to open the image, or the image may have been corrupted. Restart your computer, and then open the file again. If the red x still appears, you may have to delete the image and then 
insert it again.
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The image cannot be displayed. Your computer may not have enough memory to open the image, or the image may have been corrupted. Restart your computer, and then open the file again. If the red x still appears, you may have to delete the image and then 
insert it again.

13.  We will now arrange the components on the board	


a.  Go to the PCB document	


Begin dragging the footprints of the components over to the board	



i.  The footprints and the designators can once again be rotated using Spacebar 
while dragged	


ii.  To get a better view at any time you can use View > Fit Document or you can 
use Page Up and Page Down to zoom in and out at any time	


iii.   The designators of the components can be dragged independently of the 

component in order to make the PCB document easier to read at times	


iv.  The comments or the designators from the schematic file can be added to or 
removed from the PCB by opening the properties of the component on the PCB 
document and checking or unchecking the hide box under the ‘Designator’ and 
‘Comments’ sections.	


v.  As you drag a component around the board you will notice thin lines connecting 
the nodes of the component to other nodes around the board. These lines will jump 
to the closest connection that can be made on the board. Take notice of these lines 
and attempt to keep them short and if they are crossed try rotating the component 
until the lines are straight.	



II. Altium Designer	
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The image cannot be displayed. Your computer may not have enough memory to open the image, or the image may have been corrupted. Restart your computer, and then open the file again. If the red x still appears, you may have to delete the image and then 
insert it again.

vi.  Try to arrange your components in a compact design as many manufacturing 
houses will charge you depending on the size of the board. You will get better at 
this the more you use the software. For an example of the layout look at the image 
below	
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14.  Redefine the board shape (The black background on the screen 
is the board)	



a.  Design > Board Shape > Redefine Board Shape	


b.  The cursor will turn into a crosshair	


c.  Zoom in to get a closer view of the grid and click the first 
corner of the new board shape that you want; continue to the 
next corner and click again; once you return to the first corner 
that you clicked on there will be a circle around the crosshair 
letting you know that you are back where you started; Once you 
are finished either Right-click or press Esc in order to stop 
redefining the board. The board should look something like the 
image below	
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•  15.  Add a design rule to the board to make the GND net have a larger 
width than the other nets	


–  a.  Open the rule wizard using Design > Rule Wizard	


–  b.  When the wizard opens click next	


–  c.  On the next page type ‘GND net width’ for the name of the rule and select 

‘Width Constraint’ under the ‘Routing’ header and click next	


–  d.  Select the radio button for ‘1 Net’ since we only want this rule to apply to the 

GND net then click next	


–  e.  Change the condition value in the dropdown box to ‘GND’ then click next	


–  f.  Leave it as the highest priority and click next again	


–  g.  Click ‘Finish’ and the main design rules dialog window will open	


–  h.  Once the rule open in the window change the ‘Preferred Width’ to ‘30mil’ and 

the ‘Max Width’ to ’30 mil’ 	


–  i.  Click Apply and then OK	
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•  16.  We are finally ready to route the board	


–  a.  Auto Route > All... 	


–  b.  Click the ‘Auto Route’ button	



•  Notice the width of the GND net is wider than the other nets because of 
the rule we created. Your PCB should look like the one below	


–  c.  If you need to add a new component or add a new rule you will 

need to un-route the board using Tools > Un-Route > All and then 
use the auto route to route the board again. You will most likely do 
this several times before your finalize your design	
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•  17.  To strengthen your board add teardrops to the pads and the vias	


–  a.  Tools > Teardrops	


–  b.  Make sure the ‘All Pads’ and ‘All Vias’ checkboxes are checked 

then click OK	


•  You will notice the teardrops get added immediately without having to 

re-route the board	


•  18.  Add your initials and a revision number to the board	



–  Use Place > String to add the string to an empty space on your 
board	



–  Double click the string to open its properties	


•  i.  Change the text field to your initials and then a revision number for the 

current design of the board i.e. ‘JDR REV1.0’	


•  ii.  Change the Height of the text to ‘30mil’ and the Width to ‘6mil’	


•  iii.  Change the Font Name from ‘Default’ to ‘Serif’	
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19.  Add a keepout layer to the perimeter of your board, some 
manufactures will use this to cut your board	



a.  Select ‘Keep-Out Layer’ from the tabs at the bottom of the 
designer window; up to this point we have been working from the 
‘Top Layer’	


b.  Add a track using Place > Line. This will be similar to 
redefining the shape of the board where you can zoom in at the 
corners to make sure you are clicking the right spot and then 
zoom back out to get to the next corner more quickly. 	


c.  Add the Line to the perimeter of the board and then press Esc 
to stop adding the Line. The keepout Line should be pink 
because it is on the keepout layer like in the image below	



After routing, adding teardrops, your initials, and keepout Line the 
board should look something like this:	
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•  20.  You now need to set up the correct print settings	


–  a.  File > Default Prints	


–  b.  Check the boxes next to ‘PCB Prints’ and ‘Schematic Prints’ 

under the ‘Default Print’ column header	


–  c.  Highlight the ‘PCB Prints’ row and click the ‘Page Setup’ button 

on the bottom left of the dialog box	


–  d.  Change the ‘Scale Mode’ dropdown from the default to ‘Scaled 

Print’ then make sure that the scale is ‘1.00’ and the X and Y values 
are also ‘1.00’. This is so you can print this page and place your 
physical components on top of the layout to ensure the footprints are 
correct and there are no issues	



–  e.  Highlight the ‘Schematic Prints’ row and click the ‘Page Setup’ 
button and make sure that its ‘Scale Mode’ is left as ‘Fit Document 
On Page’	
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•  21.  It is time to create the Gerber fabrication files that can be sent to 
the board manufacturer	


–  a.  File > Fabrication Outputs > Gerber Files	


–  b.  Go to the ‘Layers’ tab on the Gerber Setup window and click the 

‘Plot Layers’ button on the bottom left	


–  c.  Select ‘Used On’ and the list of layers should then auto-populate 

the checkboxes for only the layers that you used	


–  d.  Click ‘OK’ to create the Gerber files	



•  22.  Now you can create the drill holes fabrication output files	


–  a.  File > Fabrication Outputs >  NC Drill Files	


–  b.  Keep the default settings on the NC Drill Setup window and 

click ‘OK’.	
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•  Both the Gerber files and the drill files will be added to the folder 
where you are saving the project and the drill file will just be a ‘.txt’ 
file.	



•  23.  If you choose to you can make an integrated library that will 
contain only the components that were used in your design. This could 
be useful if you are going to transfer your project to a new computer 
and you aren’t sure that all of the libraries you used will be available.	


–  a.  Design > Make Integrated Library	



•  The library will be added to the listing of all the libraries in the libraries 
tab and it will be named ‘ProjectName.IntLib’	
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•  Useful Tips	


•  0.  Check Altium www site for many training documents 

http://www.altium.com/community/trainingcenter/en/training-
manuals.cfm	



•  1.  If there is a red icon next to a file in the Project tab that means that 
the file has unsaved changes. A quick way to save all of your unsaved 
changes across files at once is…	


–  a.  File > Save All	



•   2.  If at any time you would like the schematic or the PCB document to 
fill the entire screen you can use…	


–  a.  View > Fit Document to make the components fill the screen in 

a PCB document	


–  b.  View > Fit All Objects to do the same thing in a schematic 

document	
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•  Useful Tips (cont.)	



•  3.  Page Up and Page Down can be used to zoom in and out on either 
the PCB or the schematic	



•  4.  To rotate a part	


–  a.  highlight it and press Spacebar while on the schematic 

document	


–  b.  while dragging the part press Spacebar while on the PCB 

document	
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•  Useful Tips (cont.)	


•  5.  To select several similar things at once on the PCB document the 

PCB Filter is useful	


–  a.  Click on the ‘PCB Filter’ tab that is either on the left side of you 

screen or down at the bottom right	


–  b.  Click in the large textbox where it says ‘Find items matching 

these criteria’	


–  c.  Type ‘isDesignator’ into the textbox. It should begin to 

autocomplete for you as you type enough letters	


–  d.  Click the ‘Apply’ button at the bottom of the tab	


–  e.  This will select all of the designators on the PCB document. This 

can be used if you want to change the font size of all of them at 
once.	



•   	
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Summary	



•  Assignment 6 (PCB design using Altium 
Suite)	



•  See detailed schedule in syllabus for 
assignment check-off process	



•  Also check for lab/TA hours at NEB 246 
and E-learning	




